summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-01-30 08:23:36 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-01-30 08:23:36 +0000
commit1e32e6ddd35938160bad4c4e22cfa99a12127e50 (patch)
tree442bb33e279b1d7828a31f7268d1aa725bb28b70 /target/linux/adm5120/image
parentdb7a2e3e5569840060776c5809bd7ffb248bc5ca (diff)
downloadmaster-31e0f0ae-1e32e6ddd35938160bad4c4e22cfa99a12127e50.tar.gz
master-31e0f0ae-1e32e6ddd35938160bad4c4e22cfa99a12127e50.tar.bz2
master-31e0f0ae-1e32e6ddd35938160bad4c4e22cfa99a12127e50.zip
lzma-loader: fix compiler warnings
SVN-Revision: 10321
Diffstat (limited to 'target/linux/adm5120/image')
-rw-r--r--target/linux/adm5120/image/lzma-loader/src/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/adm5120/image/lzma-loader/src/Makefile b/target/linux/adm5120/image/lzma-loader/src/Makefile
index aad845ae07..f23d040cdb 100644
--- a/target/linux/adm5120/image/lzma-loader/src/Makefile
+++ b/target/linux/adm5120/image/lzma-loader/src/Makefile
@@ -37,8 +37,8 @@ BIN_FLAGS := -O binary -R .reginfo -R .note -R .comment -R .mdebug -S
CFLAGS = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
-fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 -mno-abicalls -fno-pic \
- -ffunction-sections -pipe -mlong-calls -fno-common \
- -ffreestanding \
+ -ffunction-sections -pipe -mlong-calls -fno-common -ffreestanding \
+ -fhonour-copts \
-mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
CFLAGS += -DLOADADDR=$(LOADADDR) -D_LZMA_PROB32