summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120-2.6/patches-2.6.22/100-mtd-myloder-partition-parser.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-06-30 15:03:56 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-06-30 15:03:56 +0000
commit15a3d260fe9cd40f75c4d49f7daa11dde16753af (patch)
treef55eb0dbbb9726957fed049cdffef4434a21a2e4 /target/linux/adm5120-2.6/patches-2.6.22/100-mtd-myloder-partition-parser.patch
parenta977a42502d649be8e0dee4f3aa1ef1a7ef80328 (diff)
downloadmaster-31e0f0ae-15a3d260fe9cd40f75c4d49f7daa11dde16753af.tar.gz
master-31e0f0ae-15a3d260fe9cd40f75c4d49f7daa11dde16753af.tar.bz2
master-31e0f0ae-15a3d260fe9cd40f75c4d49f7daa11dde16753af.zip
move 2.6.22 specific patches into the right place
SVN-Revision: 7797
Diffstat (limited to 'target/linux/adm5120-2.6/patches-2.6.22/100-mtd-myloder-partition-parser.patch')
-rw-r--r--target/linux/adm5120-2.6/patches-2.6.22/100-mtd-myloder-partition-parser.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/adm5120-2.6/patches-2.6.22/100-mtd-myloder-partition-parser.patch b/target/linux/adm5120-2.6/patches-2.6.22/100-mtd-myloder-partition-parser.patch
new file mode 100644
index 0000000000..2b4381cd98
--- /dev/null
+++ b/target/linux/adm5120-2.6/patches-2.6.22/100-mtd-myloder-partition-parser.patch
@@ -0,0 +1,39 @@
+Index: linux-2.6.22-rc6/drivers/mtd/Kconfig
+===================================================================
+--- linux-2.6.22-rc6.orig/drivers/mtd/Kconfig
++++ linux-2.6.22-rc6/drivers/mtd/Kconfig
+@@ -155,6 +155,22 @@ config MTD_AFS_PARTS
+ for your particular device. It won't happen automatically. The
+ 'armflash' map driver (CONFIG_MTD_ARMFLASH) does this, for example.
+
++config MTD_MYLOADER_PARTS
++ tristate "MyLoader partition parsing"
++ depends on MIPS_ADM5120 && MTD_PARTITIONS
++ ---help---
++ MyLoader is a bootloader which allows the user to define partitions
++ in flash devices, by putting a table in the second erase block
++ on the device, similar to a partition table. This table gives the
++ offsets and lengths of the user defined partitions.
++
++ If you need code which can detect and parse these tables, and
++ register MTD 'partitions' corresponding to each image detected,
++ enable this option.
++
++ You will still need the parsing functions to be called by the driver
++ for your particular device. It won't happen automatically.
++
+ comment "User Modules And Translation Layers"
+
+ config MTD_CHAR
+Index: linux-2.6.22-rc6/drivers/mtd/Makefile
+===================================================================
+--- linux-2.6.22-rc6.orig/drivers/mtd/Makefile
++++ linux-2.6.22-rc6/drivers/mtd/Makefile
+@@ -11,6 +11,7 @@ obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
+ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
++obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
+
+ # 'Users' - code which presents functionality to userspace.
+ obj-$(CONFIG_MTD_CHAR) += mtdchar.o