summaryrefslogtreecommitdiffstats
path: root/target/linux/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-04 11:14:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-04 11:14:08 +0000
commit9abbe7a03331e090354effabae026992dc962332 (patch)
tree81a84364087dfcdbdf390d024d3037d8bb1455d1 /target/linux/Makefile
parentf082d1fddf936c406eed2eeeeef89972cf64bd22 (diff)
downloadmaster-31e0f0ae-9abbe7a03331e090354effabae026992dc962332.tar.gz
master-31e0f0ae-9abbe7a03331e090354effabae026992dc962332.tar.bz2
master-31e0f0ae-9abbe7a03331e090354effabae026992dc962332.zip
Rename 'refresh' to 'update' and make the new 'refresh' actually refresh all the patches. Also added a target package/refresh which will do this to all packages in the buildroot
SVN-Revision: 7488
Diffstat (limited to 'target/linux/Makefile')
-rw-r--r--target/linux/Makefile21
1 files changed, 2 insertions, 19 deletions
diff --git a/target/linux/Makefile b/target/linux/Makefile
index 275085448f..e124869150 100644
--- a/target/linux/Makefile
+++ b/target/linux/Makefile
@@ -7,23 +7,6 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/target.mk
-download:
- $(MAKE) -C $(BOARD)-$(KERNEL) download
+clean download prepare compile install menuconfig update refresh: FORCE
+ $(MAKE) -C $(BOARD)-$(KERNEL) $@
-prepare:
- $(MAKE) -C $(BOARD)-$(KERNEL) prepare
-
-compile:
- $(MAKE) -C $(BOARD)-$(KERNEL) compile
-
-install:
- $(MAKE) -C $(BOARD)-$(KERNEL) install
-
-refresh:
- $(MAKE) -C $(BOARD)-$(KERNEL) refresh
-
-menuconfig:
- $(MAKE) -C $(BOARD)-$(KERNEL) menuconfig
-
-clean:
- $(MAKE) -C $(BOARD)-$(KERNEL) clean