summaryrefslogtreecommitdiffstats
path: root/target/linux/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-13 22:51:49 +0200
committerFelix Fietkau <nbd@openwrt.org>2016-03-20 17:29:15 +0100
commit60c1f0f64d23003a19a07d6b9638542130f6641d (patch)
tree8fb2787f4c49baded97cd55e0c371fe1cffce2b6 /target/linux/Makefile
parentd58a09110ccfa95f06c983fe796806f2e035c9d2 (diff)
parentb3ce218b51746d3a576221ea542facf3a1703ab2 (diff)
downloadmaster-31e0f0ae-60c1f0f64d23003a19a07d6b9638542130f6641d.tar.gz
master-31e0f0ae-60c1f0f64d23003a19a07d6b9638542130f6641d.tar.bz2
master-31e0f0ae-60c1f0f64d23003a19a07d6b9638542130f6641d.zip
finally move buildroot-ng to trunk
Diffstat (limited to 'target/linux/Makefile')
-rw-r--r--target/linux/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/Makefile b/target/linux/Makefile
new file mode 100644
index 0000000000..8682fc2b9b
--- /dev/null
+++ b/target/linux/Makefile
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/target.mk
+
+download:
+ $(MAKE) -C $(BOARD)-$(KERNEL) download
+
+prepare:
+ rm -f $(TOPDIR)/.kernel.mk
+ $(MAKE) -C $(BOARD)-$(KERNEL) prepare
+
+compile:
+ $(MAKE) -C $(BOARD)-$(KERNEL) compile
+
+install:
+ $(MAKE) -C $(BOARD)-$(KERNEL) install
+
+clean:
+ $(MAKE) -C $(BOARD)-$(KERNEL) clean