summaryrefslogtreecommitdiffstats
path: root/target/linux/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-06-09 15:38:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-06-09 15:38:45 +0000
commit4c665e6ca4ce7044fbaf4e6a772b021c012f760c (patch)
tree2c5c0574cfda7d10c196399fd2791f5b57004f7b /target/linux/Makefile
parent21e09858f13eb471582ca09f1ce306a004203fb2 (diff)
downloadmaster-31e0f0ae-4c665e6ca4ce7044fbaf4e6a772b021c012f760c.tar.gz
master-31e0f0ae-4c665e6ca4ce7044fbaf4e6a772b021c012f760c.tar.bz2
master-31e0f0ae-4c665e6ca4ce7044fbaf4e6a772b021c012f760c.zip
large improvement for parallel builds. works without V=99 now and without warnings. tested with -j on an 2x dual core opteron machine
SVN-Revision: 11414
Diffstat (limited to 'target/linux/Makefile')
-rw-r--r--target/linux/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/Makefile b/target/linux/Makefile
index 8288250111..1bdd5ae149 100644
--- a/target/linux/Makefile
+++ b/target/linux/Makefile
@@ -7,6 +7,7 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/target.mk
-prereq clean download prepare compile install menuconfig oldconfig update refresh: FORCE
- TARGET_BUILD=1 $(MAKE) -C $(BOARD) $@
+export TARGET_BUILD=1
+prereq clean download prepare compile install menuconfig oldconfig update refresh: FORCE
+ @$(NO_TRACE_MAKE) -C $(BOARD) $@