summaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-04-13 01:46:09 +0200
committerJo-Philipp Wich <jo@mein.io>2016-04-13 01:46:09 +0200
commitda46d2b228f67bf0ef89d7c4905c548918763f51 (patch)
tree68c487bb45e13e930df9451f9b242342182e3fef /target/imagebuilder
parent9e0401902468a84b701b6361546b9d4a5ff71215 (diff)
downloadmaster-31e0f0ae-da46d2b228f67bf0ef89d7c4905c548918763f51.tar.gz
master-31e0f0ae-da46d2b228f67bf0ef89d7c4905c548918763f51.tar.bz2
master-31e0f0ae-da46d2b228f67bf0ef89d7c4905c548918763f51.zip
imagebuilder: fix standalone operation
Fix standalone ImageBuilders after the package layout rework. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index 106ca3d6f2..87f91ce077 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -53,7 +53,8 @@ ifeq ($(CONFIG_IB_STANDALONE),)
cp "$(PACKAGE_DIR)/$$path" "$(PKG_BUILD_DIR)/packages/$$path"; \
done
else
- $(CP) $(PACKAGE_DIR) $(PKG_BUILD_DIR)/packages
+ $(INSTALL_DIR) $(PKG_BUILD_DIR)/packages
+ find $(wildcard $(PACKAGE_SUBDIRS)) -type f -name '*.ipk' -exec $(CP) {} $(PKG_BUILD_DIR)/packages/ \;
endif
$(CP) $(TOPDIR)/target/linux $(PKG_BUILD_DIR)/target/