summaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-04-22 12:22:57 +0200
committerJo-Philipp Wich <jo@mein.io>2016-04-22 12:22:57 +0200
commitb9466382b54892c186dea356e701b5ecec86d8aa (patch)
tree60c20c6c84143be925e842de3ee7d24d796250d4 /target/imagebuilder
parent9531e0fce5766f412b8aefb97ee7d94f36fa9507 (diff)
downloadmaster-31e0f0ae-b9466382b54892c186dea356e701b5ecec86d8aa.tar.gz
master-31e0f0ae-b9466382b54892c186dea356e701b5ecec86d8aa.tar.bz2
master-31e0f0ae-b9466382b54892c186dea356e701b5ecec86d8aa.zip
imagebuilder: use correct package directory when bundling kmods and libc
The libc and kernel package files moved since the introduction of shared packages and the changed output directory layout. This causes the generated ImageBuilder archive to lack the necessary "libc" and "kernel" meta packages, leading to opkg install errors later on. Use the FeedPackageDir macro to figure out the proper source directory to use. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index 87f91ce077..b49153b889 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -47,10 +47,10 @@ endif
$(VERSION_SED) $(PKG_BUILD_DIR)/repositories.conf
ifeq ($(CONFIG_IB_STANDALONE),)
- (cd $(PACKAGE_DIR); $(FIND) -type f -name 'libc_*.ipk' -or -name 'kernel_*.ipk' -or -name 'kmod-*.ipk') | \
+ (cd $(call FeedPackageDir,libc); $(FIND) -type f -name 'libc_*.ipk' -or -name 'kernel_*.ipk' -or -name 'kmod-*.ipk') | \
while read path; do \
mkdir -p "$(PKG_BUILD_DIR)/packages/$${path%/*}"; \
- cp "$(PACKAGE_DIR)/$$path" "$(PKG_BUILD_DIR)/packages/$$path"; \
+ cp "$(call FeedPackageDir,libc)/$$path" "$(PKG_BUILD_DIR)/packages/$$path"; \
done
else
$(INSTALL_DIR) $(PKG_BUILD_DIR)/packages