summaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-07 21:01:48 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-07 21:01:48 +0000
commit65ec08d1b0718604c92f091847d2bd8b415dfbad (patch)
treed015eafb584a17d54118795ef840b0f051886711 /target/imagebuilder
parentf52a62d600df5767721dd1a756c3bcf9fc86718a (diff)
downloadmaster-31e0f0ae-65ec08d1b0718604c92f091847d2bd8b415dfbad.tar.gz
master-31e0f0ae-65ec08d1b0718604c92f091847d2bd8b415dfbad.tar.bz2
master-31e0f0ae-65ec08d1b0718604c92f091847d2bd8b415dfbad.zip
imagebuilder: align filename with SDK
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44313
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index a8ff4a3c5a..1f97cb8613 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -12,10 +12,7 @@ include $(INCLUDE_DIR)/version.mk
override MAKEFLAGS=
-PKG_OS:=$(word 2,$(subst -, ,$(shell $(HOSTCC) -dumpmachine)))
-PKG_CPU:=$(word 1,$(subst -, ,$(shell $(HOSTCC) -dumpmachine)))
-
-IB_NAME:=OpenWrt-ImageBuilder-$(if $(CONFIG_VERSION_FILENAMES),$(VERSION_NUMBER)-)$(BOARD)$(if $(SUBTARGET),_$(SUBTARGET))-for-$(PKG_OS)-$(PKG_CPU)
+IB_NAME:=OpenWrt-ImageBuilder-$(if $(CONFIG_VERSION_FILENAMES),$(VERSION_NUMBER)-)$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET)).$(HOST_OS)-$(HOST_ARCH)
PKG_BUILD_DIR:=$(BUILD_DIR)/$(IB_NAME)
IB_KDIR:=$(patsubst $(TOPDIR)/%,$(PKG_BUILD_DIR)/%,$(KERNEL_BUILD_DIR))
IB_LDIR:=$(patsubst $(TOPDIR)/%,$(PKG_BUILD_DIR)/%,$(LINUX_DIR))