summaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-06 12:31:31 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-06 12:31:31 +0000
commit188032c8e3ef79a2e869968d6e49c584b30865cf (patch)
treebe76064b23ab87f7734dbf7ac5a18b84120e3f5e /target/imagebuilder
parent330fcd48e5282485e1d5c4f339cfc1caf1027497 (diff)
downloadmaster-31e0f0ae-188032c8e3ef79a2e869968d6e49c584b30865cf.tar.gz
master-31e0f0ae-188032c8e3ef79a2e869968d6e49c584b30865cf.tar.bz2
master-31e0f0ae-188032c8e3ef79a2e869968d6e49c584b30865cf.zip
imagebuilder: don't pregenerate package index, strip host binaries
The package index is generated on first use anyway, therefore it makes no sense to continue shipping it. Also sstrip the bundled host binaries when packing the IB to save some additional space. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44293
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index ecb8ac7cf4..a8ff4a3c5a 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -56,8 +56,8 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
find $(PKG_BUILD_DIR) -name CVS -o -name .git -o -name .svn \
| $(XARGS) rm -rf
find $(STAGING_DIR_HOST)/bin -maxdepth 1 -type f -perm -u=x \
- | $(XARGS) $(SCRIPT_DIR)/bundle-libraries.sh $(PKG_BUILD_DIR)/staging_dir/host/bin
- $(MAKE) -C $(PKG_BUILD_DIR) package_index
+ | $(XARGS) $(SCRIPT_DIR)/bundle-libraries.sh $(PKG_BUILD_DIR)/staging_dir/host/bin/
+ STRIP=sstrip $(SCRIPT_DIR)/rstrip.sh $(PKG_BUILD_DIR)/staging_dir/host/bin/
$(TAR) -cf - -C $(BUILD_DIR) $(IB_NAME) | bzip2 -c > $@
download: