summaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-03 14:44:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-03 14:44:56 +0000
commit0a0bfc85079aa1c9f87bff8c5902082aedc83178 (patch)
treee9d1329506b5e93604f4c89d4071a898ec92b9da /target/imagebuilder
parent150a1b18c54b046291017d791ba15a4a06536173 (diff)
downloadmaster-31e0f0ae-0a0bfc85079aa1c9f87bff8c5902082aedc83178.tar.gz
master-31e0f0ae-0a0bfc85079aa1c9f87bff8c5902082aedc83178.tar.bz2
master-31e0f0ae-0a0bfc85079aa1c9f87bff8c5902082aedc83178.zip
images imagebuilder: Allow to add sanitized extra name
For final output image names allow user to add an extra string (which is sanitized). This is particularly useful with ImageBuilder where you may generate multiple images from the same base and for the same board, with different package selections and additional files (via FILES=). Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com> SVN-Revision: 48083
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/files/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index f612ea9abc..1056a42ca3 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -43,7 +43,7 @@ Building images:
make image PACKAGES="<pkg1> [<pkg2> [<pkg3> ...]]" # include extra packages
make image FILES="<path>" # include extra files from <path>
make image BIN_DIR="<path>" # alternative output directory for the images
-
+ make image EXTRA_IMAGE_NAME="<string>" # Add this to the output image filename (sanitized)
endef
$(eval $(call shexport,Helptext))
@@ -174,7 +174,7 @@ package_postinst: FORCE
build_image: FORCE
@echo
@echo Building images...
- $(NO_TRACE_MAKE) -C target/linux/$(BOARD)/image install TARGET_BUILD=1 IB=1 \
+ $(NO_TRACE_MAKE) -C target/linux/$(BOARD)/image install TARGET_BUILD=1 IB=1 EXTRA_IMAGE_NAME="$(EXTRA_IMAGE_NAME)" \
$(if $(USER_PROFILE),PROFILE="$(USER_PROFILE)")
clean: