summaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-09-14 16:57:03 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-09-14 16:57:03 +0000
commitfb3fb9b6c125ea8a4ce31d61b9e3f124d8d618eb (patch)
tree74bc22e4ca088450c96691b56dc2c88ac55bdae9 /target/imagebuilder
parent6497406220fd1e8e71741f2bced80983d2d7bae2 (diff)
downloadmaster-31e0f0ae-fb3fb9b6c125ea8a4ce31d61b9e3f124d8d618eb.tar.gz
master-31e0f0ae-fb3fb9b6c125ea8a4ce31d61b9e3f124d8d618eb.tar.bz2
master-31e0f0ae-fb3fb9b6c125ea8a4ce31d61b9e3f124d8d618eb.zip
imagebuilder: store package lists in cache directory
Force opkg to store the downloaded repository indizes into the cache directory as well, this way the IB can be used in an offline setting once all required files have been cached. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 46912
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/files/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index 479fa0e850..f612ea9abc 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -53,6 +53,7 @@ help: FORCE
# override variables from rules.mk
PACKAGE_DIR:=$(TOPDIR)/packages
+LISTS_DIR:=$(subst $(space),/,$(patsubst %,..,$(subst /,$(space),$(TARGET_DIR))))$(DL_DIR)
OPKG:= \
IPKG_NO_SCRIPT=1 \
IPKG_TMP="$(TMP_DIR)/ipkgtmp" \
@@ -65,6 +66,7 @@ OPKG:= \
--force-overwrite \
--force-postinstall \
--cache $(DL_DIR) \
+ --lists-dir $(LISTS_DIR) \
--offline-root $(TARGET_DIR) \
--add-dest root:/ \
--add-arch all:100 \