summaryrefslogtreecommitdiffstats
path: root/target/imagebuilder/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-10 21:52:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-10 21:52:28 +0000
commit7a6a6464971c69fa1026aeaf8fad5c79250230e9 (patch)
treea68bcf07bd0d15b68d1b990877a55002585690b9 /target/imagebuilder/Makefile
parent927fb16abb41cfeeee4e97b4baed2d5ce036ca2e (diff)
downloadmaster-31e0f0ae-7a6a6464971c69fa1026aeaf8fad5c79250230e9.tar.gz
master-31e0f0ae-7a6a6464971c69fa1026aeaf8fad5c79250230e9.tar.bz2
master-31e0f0ae-7a6a6464971c69fa1026aeaf8fad5c79250230e9.zip
Add initial version of the new Image Builder It's still a bit rough in a few places, but it seems to work for Broadcom at least - other targets untested.
SVN-Revision: 6071
Diffstat (limited to 'target/imagebuilder/Makefile')
-rw-r--r--target/imagebuilder/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
new file mode 100644
index 0000000000..470d045642
--- /dev/null
+++ b/target/imagebuilder/Makefile
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 6070 2007-01-10 21:21:59Z nbd $
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+include $(INCLUDE_DIR)/host.mk
+
+PKG_OS:=$(shell uname -s)
+PKG_CPU:=$(shell uname -m)
+
+IB_NAME:=OpenWrt-ImageBuilder-$(BOARD)-$(KERNEL)-for-$(PKG_OS)-$(PKG_CPU)
+IB_BUILD_DIR:=$(BUILD_DIR)/$(IB_NAME)
+
+all: compile
+
+$(BIN_DIR)/$(IB_NAME).tar.bz2:
+ rm -rf $(IB_BUILD_DIR)
+ mkdir -p $(IB_BUILD_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD) $(IB_BUILD_DIR)/staging_dir_$(ARCH)/bin $(IB_BUILD_DIR)/target/linux
+ $(CP) \
+ $(INCLUDE_DIR) $(SCRIPT_DIR) $(PACKAGE_DIR) \
+ $(TOPDIR)/rules.mk $(TOPDIR)/.config \
+ $(TMP_DIR)/.target.mk \
+ ./files/Makefile \
+ $(IB_BUILD_DIR)/
+ $(CP) $(STAGING_DIR)/bin/* $(IB_BUILD_DIR)/staging_dir_$(ARCH)/bin
+ $(CP) $(TOPDIR)/target/linux/* $(IB_BUILD_DIR)/target/linux
+ rm -rf $(IB_BUILD_DIR)/target/linux/*/patches
+ -cp $(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)/* $(IB_BUILD_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD) # don't copy subdirectories here
+ find $(IB_BUILD_DIR) -name .svn | xargs rm -rf
+ find $(IB_BUILD_DIR) -name CVS | xargs rm -rf
+ (cd $(BUILD_DIR); \
+ tar cfj $@ $(IB_NAME); \
+ )
+
+download:
+prepare:
+compile: $(BIN_DIR)/$(IB_NAME).tar.bz2
+install: compile
+
+clean:
+ rm -rf $(IB_BUILD_DIR) $(BIN_DIR)/$(IB_NAME).tar.bz2