summaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-05-11 20:13:58 +0200
committerFelix Fietkau <nbd@nbd.name>2016-05-11 20:14:00 +0200
commit4a31037a34167a41705de319cdf989a63519debb (patch)
treee6af96df9a1ed4125ca89313559e80f976cd70b0 /scripts
parentb0cf769008bc38f386c977f38f80de0fef098355 (diff)
downloadmaster-31e0f0ae-4a31037a34167a41705de319cdf989a63519debb.tar.gz
master-31e0f0ae-4a31037a34167a41705de319cdf989a63519debb.tar.bz2
master-31e0f0ae-4a31037a34167a41705de319cdf989a63519debb.zip
build: avoid including profiles/*.mk
Generate the active profile name in menuconfig context Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/metadata.pl12
1 files changed, 12 insertions, 0 deletions
diff --git a/scripts/metadata.pl b/scripts/metadata.pl
index f5afb1e47b..260d06d712 100755
--- a/scripts/metadata.pl
+++ b/scripts/metadata.pl
@@ -337,6 +337,18 @@ EOF
}
}
print <<EOF;
+config TARGET_PROFILE
+ string
+EOF
+ foreach my $target (@target) {
+ my $profiles = $target->{profiles};
+ foreach my $profile (@$profiles) {
+ print "\tdefault \"$profile->{id}\" if TARGET_$target->{conf}_$profile->{id}\n";
+ }
+ }
+
+ print <<EOF;
+
config TARGET_ARCH_PACKAGES
string