summaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-01-10 11:59:42 +0000
committerNicolas Thill <nico@openwrt.org>2007-01-10 11:59:42 +0000
commitbf3654cc107890bf2bad0393cc12a372fbbe8167 (patch)
tree4234bb873b0324bb706d86a715fe4b08a237e305 /scripts
parent0362ccb83b84811147849927aa7af4f39e5f04b2 (diff)
downloadmaster-31e0f0ae-bf3654cc107890bf2bad0393cc12a372fbbe8167.tar.gz
master-31e0f0ae-bf3654cc107890bf2bad0393cc12a372fbbe8167.tar.bz2
master-31e0f0ae-bf3654cc107890bf2bad0393cc12a372fbbe8167.zip
add a hack to allow source package names in Build-Depends: (PKG_BUILDDEP)
SVN-Revision: 6060
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/gen_deps.pl2
1 files changed, 2 insertions, 0 deletions
diff --git a/scripts/gen_deps.pl b/scripts/gen_deps.pl
index af206f0047..0fc80aae85 100755
--- a/scripts/gen_deps.pl
+++ b/scripts/gen_deps.pl
@@ -28,6 +28,8 @@ while ($line = <>) {
$line =~ /^Source-Makefile: \s*(.+\/([^\/]+)\/Makefile)\s*$/ and do {
$makefile = $1;
$src = $2;
+ defined $pkg{$src} or $pkg{$src} = {};
+ $pkg{$src}->{src} = $src;
};
$line =~ /^Package: \s*(.+)\s*$/ and do {
$name = $1;