summaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-10 16:01:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-10 16:01:07 +0000
commita80df62566942aa4bff340fbc752d524ad7c7a02 (patch)
treecaec96db1a18f6afc07dc0a269261a190aa512ea /scripts
parentbf3654cc107890bf2bad0393cc12a372fbbe8167 (diff)
downloadmaster-31e0f0ae-a80df62566942aa4bff340fbc752d524ad7c7a02.tar.gz
master-31e0f0ae-a80df62566942aa4bff340fbc752d524ad7c7a02.tar.bz2
master-31e0f0ae-a80df62566942aa4bff340fbc752d524ad7c7a02.zip
include default package set in .target.mk
SVN-Revision: 6061
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/gen_target_mk.pl5
1 files changed, 3 insertions, 2 deletions
diff --git a/scripts/gen_target_mk.pl b/scripts/gen_target_mk.pl
index 0e4d50a74c..2492478f9b 100755
--- a/scripts/gen_target_mk.pl
+++ b/scripts/gen_target_mk.pl
@@ -70,7 +70,7 @@ foreach $target (@target) {
$profiles_eval .= "
\$(eval \$(call Profile,$conf\_$profile->{id}))"
}
- print <<EOF
+ print "
ifeq (\$(CONFIG_LINUX_$conf),y)
define Target
KERNEL:=$target->{kernel}
@@ -78,9 +78,10 @@ ifeq (\$(CONFIG_LINUX_$conf),y)
LINUX_VERSION:=$target->{version}
LINUX_RELEASE:=$target->{release}
LINUX_KARCH:=$target->{karch}
+ DEFAULT_PACKAGES:=".join(" ", @{$target->{packages}})."
endef$profiles_def
endif$profiles_eval
-EOF
+"
}
print "\$(eval \$(call Target))\n";