summaryrefslogtreecommitdiffstats
path: root/scripts/deptest.sh
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2010-11-03 00:27:50 +0000
committerMichael Büsch <mb@bu3sch.de>2010-11-03 00:27:50 +0000
commitba91f56bf41b2623622e026dc54babd002cb5ac8 (patch)
treee5f01ff4d0f2c0ff09db244446cec0f4415cb933 /scripts/deptest.sh
parent87fe1d36d3e9eca0ac095935266b4ce65d152caa (diff)
downloadmaster-31e0f0ae-ba91f56bf41b2623622e026dc54babd002cb5ac8.tar.gz
master-31e0f0ae-ba91f56bf41b2623622e026dc54babd002cb5ac8.tar.bz2
master-31e0f0ae-ba91f56bf41b2623622e026dc54babd002cb5ac8.zip
deptest: Check for .config
SVN-Revision: 23810
Diffstat (limited to 'scripts/deptest.sh')
-rwxr-xr-xscripts/deptest.sh2
1 files changed, 2 insertions, 0 deletions
diff --git a/scripts/deptest.sh b/scripts/deptest.sh
index ad378bafcd..3a81659f7b 100755
--- a/scripts/deptest.sh
+++ b/scripts/deptest.sh
@@ -22,6 +22,8 @@ die()
[ -f "$BASEDIR/include/toplevel.mk" ] || \
die "Error: Could not find buildsystem base directory"
+[ -f "$BASEDIR/.config" ] || \
+ die "The buildsystem is not configured. Please run make menuconfig."
cd "$BASEDIR" || die "Failed to enter base directory"
mkdir -p "$STAMP_DIR_SUCCESS" "$STAMP_DIR_FAILED" "$BUILD_DIR" "$BUILD_DIR_HOST" "$LOG_DIR"