summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-11-29 10:59:51 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-11-29 10:59:51 +0000
commitf6b57149af3edf52773f9c3abf5e5e0454bcb49c (patch)
tree7606e2550f2bb769a33e8f7f3dae3546c6146603 /rules.mk
parent08a62d8d8a355e9589106309926a18ffb92a9761 (diff)
downloadmaster-31e0f0ae-f6b57149af3edf52773f9c3abf5e5e0454bcb49c.tar.gz
master-31e0f0ae-f6b57149af3edf52773f9c3abf5e5e0454bcb49c.tar.bz2
master-31e0f0ae-f6b57149af3edf52773f9c3abf5e5e0454bcb49c.zip
FPU type should not interfere with the ABI selection. Also make sure we either do real soft-float or hard-float on ARM, with the right options.
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 38943
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/rules.mk b/rules.mk
index 80e07d11a2..47ba928de5 100644
--- a/rules.mk
+++ b/rules.mk
@@ -168,9 +168,16 @@ TARGET_PATH_PKG:=$(STAGING_DIR)/host/bin:$(TARGET_PATH)
ifeq ($(CONFIG_SOFT_FLOAT),y)
SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
- TARGET_CFLAGS+= -msoft-float
+ ifeq ($(CONFIG_arm),y)
+ TARGET_CFLAGS+= -mfloat-abi=soft
+ else
+ TARGET_CFLAGS+= -msoft-float
+ endif
else
SOFT_FLOAT_CONFIG_OPTION:=
+ ifeq ($(CONFIG_arm),y)
+ TARGET_CFLAGS+= -mfloat-abi=hard
+ endif
endif
export PATH:=$(TARGET_PATH)