summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-04-05 12:36:23 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-04-05 12:36:23 +0000
commite03292226618c68f219f41d745f92172687690dd (patch)
tree30339621d48222e18d49491444ca6c9bdc3591be /rules.mk
parent348cae15d2934f07a6c584261c2bee49cc43bbbd (diff)
downloadmaster-31e0f0ae-e03292226618c68f219f41d745f92172687690dd.tar.gz
master-31e0f0ae-e03292226618c68f219f41d745f92172687690dd.tar.bz2
master-31e0f0ae-e03292226618c68f219f41d745f92172687690dd.zip
toolchain: allow choosing the MIPS64 user-land ABI
Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 36205
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/rules.mk b/rules.mk
index d9d38374fa..2333f2aaf5 100644
--- a/rules.mk
+++ b/rules.mk
@@ -73,6 +73,11 @@ endif
ifdef CONFIG_HAS_SPE_FPU
TARGET_SUFFIX:=$(TARGET_SUFFIX)spe
endif
+ifdef CONFIG_MIPS64_ABI
+ ifneq ($(CONFIG_MIPS64_ABI_O32),y)
+ ARCH_SUFFIX:=$(ARCH_SUFFIX)_$(subst ",,$(CONFIG_MIPS64_ABI))
+ endif
+endif
DL_DIR:=$(if $(call qstrip,$(CONFIG_DOWNLOAD_FOLDER)),$(call qstrip,$(CONFIG_DOWNLOAD_FOLDER)),$(TOPDIR)/dl)
BIN_DIR:=$(TOPDIR)/bin/$(BOARD)