summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-04-05 12:35:56 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-04-05 12:35:56 +0000
commitbe5d8e6c878c92f8100c634af01c302717704b2f (patch)
treef84c27894c074bb7e1ce81bdfb7b48c9d22cbf08 /rules.mk
parent5b3445c60bb23b7414119482fb784f68fbcc82db (diff)
downloadmaster-31e0f0ae-be5d8e6c878c92f8100c634af01c302717704b2f.tar.gz
master-31e0f0ae-be5d8e6c878c92f8100c634af01c302717704b2f.tar.bz2
master-31e0f0ae-be5d8e6c878c92f8100c634af01c302717704b2f.zip
rules.mk: MIPS16 builds get a different toolchain
To be safe, build "m16" into the toolchain and target architecture the same way mips32r2 does: target-mips_r2_m16_uClibc-0.9.33.2 toolchain-mips_r2_m16_gcc-4.6-linaro_uClibc-0.9.33.2 Signed-off-by: Jay Carlson <nop@nop.com> Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 36198
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/rules.mk b/rules.mk
index ae7a8407e3..59ab50b922 100644
--- a/rules.mk
+++ b/rules.mk
@@ -65,6 +65,7 @@ ifneq ($(filter -mips%r2,$(TARGET_OPTIMIZATION)),)
endif
ifneq ($(findstring -mips16,$(TARGET_OPTIMIZATION)),)
TARGET_ASFLAGS_OVERRIDE:=-mno-mips16
+ ARCH_SUFFIX:= $(ARCH_SUFFIX)_m16
endif
ifdef CONFIG_HAS_SPE_FPU
TARGET_SUFFIX:=$(TARGET_SUFFIX)spe