summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-10 12:04:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-10 12:04:09 +0000
commit940bc81bc2dee35f01c7ca6e5e588f62a20b82f8 (patch)
treea4e318f63ca5e48479c84defaedd813ad93ba523 /rules.mk
parentb613c96d94bcdcda7abb3be68ea1c281ce5fbb47 (diff)
downloadmaster-31e0f0ae-940bc81bc2dee35f01c7ca6e5e588f62a20b82f8.tar.gz
master-31e0f0ae-940bc81bc2dee35f01c7ca6e5e588f62a20b82f8.tar.bz2
master-31e0f0ae-940bc81bc2dee35f01c7ca6e5e588f62a20b82f8.zip
build: add -Wno-error=unused-result to target cflags
Many glibc functions have __warn_unused_result__ in so many different core functions, and failing the build for all of those simply does not make any sense Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 47440
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/rules.mk b/rules.mk
index 348b45d6e1..f749863d7c 100644
--- a/rules.mk
+++ b/rules.mk
@@ -143,7 +143,7 @@ ifndef DUMP
-include $(TOOLCHAIN_DIR)/info.mk
export GCC_HONOUR_COPTS:=0
TARGET_CROSS:=$(if $(TARGET_CROSS),$(TARGET_CROSS),$(OPTIMIZE_FOR_CPU)-openwrt-linux$(if $(TARGET_SUFFIX),-$(TARGET_SUFFIX))-)
- TARGET_CFLAGS+= -fhonour-copts -Wno-error=unused-but-set-variable
+ TARGET_CFLAGS+= -fhonour-copts -Wno-error=unused-but-set-variable -Wno-error=unused-result
TARGET_CPPFLAGS+= -I$(TOOLCHAIN_DIR)/usr/include
ifeq ($(CONFIG_USE_MUSL),y)
TARGET_CPPFLAGS+= -I$(TOOLCHAIN_DIR)/include/fortify