summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-01-16 01:25:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-01-16 01:25:06 +0000
commit8740549c573adf52c1b73f720e1ca52d15f90979 (patch)
tree0dae1a4b29dfadc27530ea39292dac07ff89bff8 /rules.mk
parent9299345c7f5305cd29dedc3b30c74658370a6875 (diff)
downloadmaster-31e0f0ae-8740549c573adf52c1b73f720e1ca52d15f90979.tar.gz
master-31e0f0ae-8740549c573adf52c1b73f720e1ca52d15f90979.tar.bz2
master-31e0f0ae-8740549c573adf52c1b73f720e1ca52d15f90979.zip
mpc85xx: add a new 'spe_fpu' feature flag for the FPU used on freescale powerpc cpus The SPE FPU is ABI-incompatible with the regular powerpc FPU, this needs to be reflected in the toolchain target name. Fixes floating point crashes in user space
SVN-Revision: 25018
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/rules.mk b/rules.mk
index 09b4f5447a..2e66bea4cf 100644
--- a/rules.mk
+++ b/rules.mk
@@ -69,6 +69,9 @@ endif
ifneq ($(findstring -march=armv5te,$(TARGET_OPTIMIZATION)),)
ARCH_SUFFIX:=_v5te
endif
+ifdef CONFIG_HAS_SPE_FPU
+ TARGET_SUFFIX:=$(TARGET_SUFFIX)spe
+endif
DL_DIR:=$(if $(call qstrip,$(CONFIG_DOWNLOAD_FOLDER)),$(call qstrip,$(CONFIG_DOWNLOAD_FOLDER)),$(TOPDIR)/dl)
BIN_DIR:=$(TOPDIR)/bin/$(BOARD)