summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-05 16:57:18 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-05 16:57:18 +0000
commit78f476ed025db36a801c1bfeff025444ac1d702d (patch)
tree819eaef3470a31f112cc0f27e4856af3ba815fe8 /rules.mk
parent9886084b94568328481aaa20c3c3501f78da335e (diff)
downloadmaster-31e0f0ae-78f476ed025db36a801c1bfeff025444ac1d702d.tar.gz
master-31e0f0ae-78f476ed025db36a801c1bfeff025444ac1d702d.tar.bz2
master-31e0f0ae-78f476ed025db36a801c1bfeff025444ac1d702d.zip
include: declare variables formerly set in tmp/.host.mk
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44272
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/rules.mk b/rules.mk
index 70768f055d..e5f681aeb2 100644
--- a/rules.mk
+++ b/rules.mk
@@ -210,6 +210,12 @@ CP:=cp -fpR
LN:=ln -sf
XARGS:=xargs -r
+BASH:=$(STAGING_DIR_HOST)/bin/bash
+TAR:=$(STAGING_DIR_HOST)/bin/tar
+FIND:=$(STAGING_DIR_HOST)/bin/find
+PATCH:=$(STAGING_DIR_HOST)/bin/patch
+PYTHON:=$(STAGING_DIR_HOST)/bin/python
+
INSTALL_BIN:=install -m0755
INSTALL_DIR:=install -d -m0755
INSTALL_DATA:=install -m0644