summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-04-06 21:49:15 +0200
committerJo-Philipp Wich <jo@mein.io>2016-04-06 21:49:15 +0200
commit54fbe8afdd28d0619d8ccede9fcf183d745584a4 (patch)
treec27735daa43e6def5169676104fe7532bc064bb9 /rules.mk
parent7322cca9fab00163778d5e44615ed05f01097851 (diff)
downloadmaster-31e0f0ae-54fbe8afdd28d0619d8ccede9fcf183d745584a4.tar.gz
master-31e0f0ae-54fbe8afdd28d0619d8ccede9fcf183d745584a4.tar.bz2
master-31e0f0ae-54fbe8afdd28d0619d8ccede9fcf183d745584a4.zip
rules.mk: introduce new variable OUTPUT_DIR
Introduce a new variable OUTPUT_DIR which refers to the parent bin/ directory without the architecture specific component. Also construct the BIN_DIR variable based on OUTPUT_DIR now and add both target and subtarget components to it to prevent different subtargets from overwriting each others files in bin/. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/rules.mk b/rules.mk
index 22807da7f0..12a79ba30c 100644
--- a/rules.mk
+++ b/rules.mk
@@ -1,5 +1,6 @@
#
# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2016 LEDE Project
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -54,6 +55,7 @@ CFLAGS:=
ARCH:=$(subst i486,i386,$(subst i586,i386,$(subst i686,i386,$(call qstrip,$(CONFIG_ARCH)))))
ARCH_PACKAGES:=$(call qstrip,$(CONFIG_TARGET_ARCH_PACKAGES))
BOARD:=$(call qstrip,$(CONFIG_TARGET_BOARD))
+SUBTARGET:=$(call qstrip,$(CONFIG_TARGET_SUBTARGET))
TARGET_OPTIMIZATION:=$(call qstrip,$(CONFIG_TARGET_OPTIMIZATION))
export EXTRA_OPTIMIZATION:=$(filter-out -fno-plt,$(call qstrip,$(CONFIG_EXTRA_OPTIMIZATION)))
TARGET_SUFFIX=$(call qstrip,$(CONFIG_TARGET_SUFFIX))
@@ -93,7 +95,8 @@ ifdef CONFIG_MIPS64_ABI
endif
DL_DIR:=$(if $(call qstrip,$(CONFIG_DOWNLOAD_FOLDER)),$(call qstrip,$(CONFIG_DOWNLOAD_FOLDER)),$(TOPDIR)/dl)
-BIN_DIR:=$(if $(call qstrip,$(CONFIG_BINARY_FOLDER)),$(call qstrip,$(CONFIG_BINARY_FOLDER)),$(TOPDIR)/bin/$(BOARD))
+OUTPUT_DIR:=$(if $(call qstrip,$(CONFIG_BINARY_FOLDER)),$(call qstrip,$(CONFIG_BINARY_FOLDER)),$(TOPDIR)/bin)
+BIN_DIR:=$(OUTPUT_DIR)/targets/$(BOARD)/$(SUBTARGET)
INCLUDE_DIR:=$(TOPDIR)/include
SCRIPT_DIR:=$(TOPDIR)/scripts
BUILD_DIR_BASE:=$(TOPDIR)/build_dir