summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-04-02 14:27:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-04-02 14:27:51 +0000
commit21ff098352570f3bd7a161254207e8c40508c8e4 (patch)
treee20656607ee21de0cd9bb4638e2843c187c0c4b7 /rules.mk
parent9e4f19cd42624132047b683fdc5f12c65f5ca827 (diff)
downloadmaster-31e0f0ae-21ff098352570f3bd7a161254207e8c40508c8e4.tar.gz
master-31e0f0ae-21ff098352570f3bd7a161254207e8c40508c8e4.tar.bz2
master-31e0f0ae-21ff098352570f3bd7a161254207e8c40508c8e4.zip
set TOOLCHAIN_DIR var when using external toolchain
This patch allows to use the openwrt toolchain as external toolchain for the same project. See bug #9131 for details. Signed-off-by: Sven Bachmann <dev@mcbachmann.de> SVN-Revision: 26405
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/rules.mk b/rules.mk
index 428258f5f4..a3516a57a0 100644
--- a/rules.mk
+++ b/rules.mk
@@ -140,6 +140,7 @@ ifndef DUMP
ifneq ($(TOOLCHAIN_LIB_DIRS),)
TARGET_LDFLAGS+= $(patsubst %,-L%,$(TOOLCHAIN_LIB_DIRS))
endif
+ TOOLCHAIN_DIR:=$(TOOLCHAIN_ROOT_DIR)
endif
endif
endif