summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-09-12 20:49:54 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-09-12 20:49:54 +0000
commit064e7c8f00ebc1721553c0fcb312f809b00e179a (patch)
treea12eb3995a6a04ae7ee0fa2f876de77c22a91ca2 /rules.mk
parent78539bfa4f6e2af404934fee326d607e6414980e (diff)
downloadmaster-31e0f0ae-064e7c8f00ebc1721553c0fcb312f809b00e179a.tar.gz
master-31e0f0ae-064e7c8f00ebc1721553c0fcb312f809b00e179a.tar.bz2
master-31e0f0ae-064e7c8f00ebc1721553c0fcb312f809b00e179a.zip
Implement an ARCH_PACKAGES variable which defaults to BOARD but can be overridden on a per-subtarget basis. This is intended for targets such as adm5120 and malta which support both big and little endianess and will replace the target specific exceptions in package-defaults and Image Builder.
SVN-Revision: 23029
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/rules.mk b/rules.mk
index 1ce28e1bba..e07b06c2e5 100644
--- a/rules.mk
+++ b/rules.mk
@@ -31,6 +31,7 @@ strip_last=$(patsubst %.$(lastword $(subst .,$(space),$(1))),%,$(1))
_SINGLE=export MAKEFLAGS=$(space);
CFLAGS:=
ARCH:=$(subst i486,i386,$(subst i586,i386,$(subst i686,i386,$(call qstrip,$(CONFIG_ARCH)))))
+ARCH_PACKAGES:=$(call qstrip,$(CONFIG_TARGET_ARCH_PACKAGES))
BOARD:=$(call qstrip,$(CONFIG_TARGET_BOARD))
TARGET_OPTIMIZATION:=$(call qstrip,$(CONFIG_TARGET_OPTIMIZATION))
TARGET_SUFFIX=$(call qstrip,$(CONFIG_TARGET_SUFFIX))