summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2008-06-10 07:18:41 +0000
committerJohn Crispin <john@openwrt.org>2008-06-10 07:18:41 +0000
commitc9d9f8045c5aebdfeb96d7f9833927751d854bc1 (patch)
tree23ca4ef3aee50468acaf784ace88dfa0d2bf0fec /rules.mk
parent80e70b78fd12c0ace10bb0f505aa4c8593b8981c (diff)
downloadmaster-31e0f0ae-c9d9f8045c5aebdfeb96d7f9833927751d854bc1.tar.gz
master-31e0f0ae-c9d9f8045c5aebdfeb96d7f9833927751d854bc1.tar.bz2
master-31e0f0ae-c9d9f8045c5aebdfeb96d7f9833927751d854bc1.zip
adds missing patch for native toolchain
SVN-Revision: 11425
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk14
1 files changed, 9 insertions, 5 deletions
diff --git a/rules.mk b/rules.mk
index 6d6dab09bc..7153a04c2d 100644
--- a/rules.mk
+++ b/rules.mk
@@ -120,11 +120,15 @@ TARGET_CONFIGURE_OPTS:= \
SIZE=$(TARGET_CROSS)size
# strip an entire directory
-RSTRIP:= \
- NM="$(TARGET_CROSS)nm" \
- STRIP="$(STRIP)" \
- STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment" \
- $(SCRIPT_DIR)/rstrip.sh
+ifneq ($(CONFIG_BUILD_DEVELOPER_SYSTEM),)
+ RSTRIP:=:
+else
+ RSTRIP:= \
+ NM="$(TARGET_CROSS)nm" \
+ STRIP="$(STRIP)" \
+ STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment" \
+ $(SCRIPT_DIR)/rstrip.sh
+endif
ifeq ($(CONFIG_ENABLE_LOCALE),true)
DISABLE_NLS:=