summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-09 01:15:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-09 01:15:59 +0000
commitb6f0cb53669e8b96fd15e6913faf1697f602a6b8 (patch)
treee4d070cc362de422bf7ae7438eff02bb06d875c3 /rules.mk
parent28f3acc0317a622b084814f65b523e6f5ba234d5 (diff)
downloadmaster-31e0f0ae-b6f0cb53669e8b96fd15e6913faf1697f602a6b8.tar.gz
master-31e0f0ae-b6f0cb53669e8b96fd15e6913faf1697f602a6b8.tar.bz2
master-31e0f0ae-b6f0cb53669e8b96fd15e6913faf1697f602a6b8.zip
prepend $(STAGING_DIR)/host to the PATH only in target-package stampfile targets, should fix usage of cross tools with host builds
SVN-Revision: 14800
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/rules.mk b/rules.mk
index 315e998b94..96ae8d57f7 100644
--- a/rules.mk
+++ b/rules.mk
@@ -65,7 +65,8 @@ TARGET_ROOTFS_DIR?=$(if $(call qstrip,$(CONFIG_TARGET_ROOTFS_DIR)),$(call qstrip
TARGET_DIR:=$(TARGET_ROOTFS_DIR)/root-$(BOARD)
DEBUG_DIR:=$(BUILD_DIR)/debug-$(BOARD)
-TARGET_PATH:=$(TOOLCHAIN_DIR)/usr/bin:$(STAGING_DIR_HOST)/bin:$(STAGING_DIR)/host/bin:$(PATH)
+TARGET_PATH:=$(TOOLCHAIN_DIR)/usr/bin:$(STAGING_DIR_HOST)/bin:$(PATH)
+TARGET_PATH_PKG:=$(STAGING_DIR)/host/bin:$(TARGET_PATH)
TARGET_CFLAGS:=$(TARGET_OPTIMIZATION)$(if $(CONFIG_DEBUG), -g3)
TARGET_CPPFLAGS:=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
TARGET_LDFLAGS:=-L$(TOOLCHAIN_DIR)/usr/lib -L$(TOOLCHAIN_DIR)/lib -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib