summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-01-14 12:28:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-01-14 12:28:53 +0000
commit903af2c13e1eb54358f5c88567aeee1eef9eee60 (patch)
tree24c8cbedb81e92ba928430aff8ff5be8a7a4968d /rules.mk
parentf9ddabb579cafd2518a3a59d0cefe66c95bccb3f (diff)
downloadmaster-31e0f0ae-903af2c13e1eb54358f5c88567aeee1eef9eee60.tar.gz
master-31e0f0ae-903af2c13e1eb54358f5c88567aeee1eef9eee60.tar.bz2
master-31e0f0ae-903af2c13e1eb54358f5c88567aeee1eef9eee60.zip
add $(TOOLCHAIN_DIR)/lib to $(TARGET_LDFLAGS) to ensure that all packages process this correctly - fixes build errors with openldap/php5
SVN-Revision: 10190
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/rules.mk b/rules.mk
index 7ac39b123e..da16ed4466 100644
--- a/rules.mk
+++ b/rules.mk
@@ -59,7 +59,7 @@ endif
TARGET_PATH:=$(TOOLCHAIN_DIR)/bin:$(STAGING_DIR_HOST)/bin:$(STAGING_DIR)/host/bin:$(PATH)
TARGET_CFLAGS:=$(TARGET_OPTIMIZATION) -fhonour-copts
TARGET_CPPFLAGS:=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
-TARGET_LDFLAGS:=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
+TARGET_LDFLAGS:=-L$(TOOLCHAIN_DIR)/lib -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
ifeq ($(CONFIG_SOFT_FLOAT),y)
SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft