summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-21 02:14:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-21 02:14:50 +0000
commit3133fefe06562d0ce7984230425128634de27f2f (patch)
tree8df13d10fa44e4a5f514430f10185173143cee39 /rules.mk
parent69d76bb482633a1f0af1dc635a3286062e0397cf (diff)
downloadmaster-31e0f0ae-3133fefe06562d0ce7984230425128634de27f2f.tar.gz
master-31e0f0ae-3133fefe06562d0ce7984230425128634de27f2f.tar.bz2
master-31e0f0ae-3133fefe06562d0ce7984230425128634de27f2f.zip
pass the CFLAGS through the environment on compile and fix a few packages
SVN-Revision: 6154
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/rules.mk b/rules.mk
index 3afdab67c2..0a958c2d58 100644
--- a/rules.mk
+++ b/rules.mk
@@ -69,6 +69,9 @@ ifneq ($(CONFIG_CCACHE),)
TARGET_CC:= ccache $(TARGET_CC)
endif
+EXTRA_CPPFLAGS := -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
+EXTRA_LDFLAGS := -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
+
TARGET_CONFIGURE_OPTS:= \
AR=$(TARGET_CROSS)ar \
AS="$(TARGET_CC) -c $(TARGET_CFLAGS)" \