summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2010-03-05 20:26:14 +0000
committerTravis Kemen <thepeople@openwrt.org>2010-03-05 20:26:14 +0000
commit137c26b7cb7a37012feb1c39ff11e09527d82ddd (patch)
treeb7eef516afb891d1fe71ed4a65d7c606c40bbb77 /rules.mk
parentfab2cb71e15e61b7ba64259c15c28f588fd08ced (diff)
downloadmaster-31e0f0ae-137c26b7cb7a37012feb1c39ff11e09527d82ddd.tar.gz
master-31e0f0ae-137c26b7cb7a37012feb1c39ff11e09527d82ddd.tar.bz2
master-31e0f0ae-137c26b7cb7a37012feb1c39ff11e09527d82ddd.zip
there are quite a lot of package using ln -sf in their Makefile, so this patch adds
LN:=ln -sf to rules.mk -Raphael SVN-Revision: 19998
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/rules.mk b/rules.mk
index 942c7b416f..a7d7a34d55 100644
--- a/rules.mk
+++ b/rules.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -142,6 +142,7 @@ TARGET_CXX:=$(if $(CONFIG_INSTALL_LIBSTDCPP),$(TARGET_CROSS)g++,no)
PATCH:=$(SCRIPT_DIR)/patch-kernel.sh
SED:=$(STAGING_DIR_HOST)/bin/sed -i -e
CP:=cp -fpR
+LN:=ln -sf
INSTALL_BIN:=install -m0755
INSTALL_DIR:=install -d -m0755