summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-04-18 17:35:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-04-18 17:35:46 +0000
commit1099e2d679328043c2c317169054f16a86b5d45b (patch)
tree08f2beef40c9c1fb7483e72aa597949b73f355ad /rules.mk
parent532654e3c6237f9867c35ca38b3d4967d4e054ff (diff)
downloadmaster-31e0f0ae-1099e2d679328043c2c317169054f16a86b5d45b.tar.gz
master-31e0f0ae-1099e2d679328043c2c317169054f16a86b5d45b.tar.bz2
master-31e0f0ae-1099e2d679328043c2c317169054f16a86b5d45b.zip
the default_subtargets template was a bad idea, since different makefiles require different types of dependencies for subtargets. nuke it...
SVN-Revision: 7003
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk21
1 files changed, 0 insertions, 21 deletions
diff --git a/rules.mk b/rules.mk
index 9ec98961ce..0ce75f55c0 100644
--- a/rules.mk
+++ b/rules.mk
@@ -131,27 +131,6 @@ $(call shvar,$(1))=$$(call $(1))
export $(call shvar,$(1))
endef
-# Default targets for subdirectory calls
-# Parameters:
-# 1: dependencies for the prepare step
-define default_subtargets
- %-download: FORCE
- $$(MAKE) -C $$(patsubst %-download,%,$$@) download
-
- %-prepare: $(1) FORCE
- $$(MAKE) -C $$(patsubst %-prepare,%,$$@) prepare
-
- %-compile: %-prepare
- $$(MAKE) -C $$(patsubst %-compile,%,$$@) compile
-
- %-install:
- $$(MAKE) -C $$(patsubst %-install,%,$$@) install
-
- %-clean: FORCE
- @$$(MAKE) -C $$(patsubst %-clean,%,$$@) clean
-endef
-
-
all:
FORCE: ;
.PHONY: FORCE