summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-06 00:56:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-06 00:56:36 +0000
commit063729570437fe82c326df2d1630be73828e0539 (patch)
tree239ceb3b0a33dd5bf107f0ebaf42a768bc5a1b08 /rules.mk
parent2e401154da05f832692f0fd6ab82d51a7c8dbe2f (diff)
downloadmaster-31e0f0ae-063729570437fe82c326df2d1630be73828e0539.tar.gz
master-31e0f0ae-063729570437fe82c326df2d1630be73828e0539.tar.bz2
master-31e0f0ae-063729570437fe82c326df2d1630be73828e0539.zip
fix overzealous kmod stripping - it killed kernel module parameters (#1301)
SVN-Revision: 6271
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/rules.mk b/rules.mk
index 42e9978591..b63fcf31c8 100644
--- a/rules.mk
+++ b/rules.mk
@@ -88,7 +88,7 @@ TARGET_CONFIGURE_OPTS:= \
# strip an entire directory
RSTRIP:= \
STRIP="$(STRIP)" \
- STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment" \
+ STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment -w -K '__mod*'" \
$(SCRIPT_DIR)/rstrip.sh
# where to build (and put) .ipk packages