summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-01-06 15:56:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-01-06 15:56:30 +0000
commit0434df7feedd13445734a39b7d58f6206c97927f (patch)
treebc834360a1aeac2ccede69b60066e121a2749d32 /rules.mk
parent24460388fc7e4b35501f7506e48825d9b8fca315 (diff)
downloadmaster-31e0f0ae-0434df7feedd13445734a39b7d58f6206c97927f.tar.gz
master-31e0f0ae-0434df7feedd13445734a39b7d58f6206c97927f.tar.bz2
master-31e0f0ae-0434df7feedd13445734a39b7d58f6206c97927f.zip
add the make variable LIBGCC_S, which points to the correct libgcc ldflag (avr32 only has a static library, most targets use the dynamic one)
SVN-Revision: 13892
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/rules.mk b/rules.mk
index 614feb6fc5..31e073036d 100644
--- a/rules.mk
+++ b/rules.mk
@@ -67,6 +67,7 @@ TARGET_PATH:=$(TOOLCHAIN_DIR)/bin:$(STAGING_DIR_HOST)/bin:$(STAGING_DIR)/host/bi
TARGET_CFLAGS:=$(TARGET_OPTIMIZATION)$(if $(CONFIG_DEBUG), -g3)
TARGET_CPPFLAGS:=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
TARGET_LDFLAGS:=-L$(TOOLCHAIN_DIR)/lib -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
+LIBGCC_S=$(if $(wildcard $(TOOLCHAIN_DIR)/lib/libgcc_s.so),-lgcc_s,$(wildcard $(TOOLCHAIN_DIR)/lib/gcc/*/*/libgcc.a))
ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
-include $(TOOLCHAIN_DIR)/info.mk