summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@googlemail.com>2016-09-18 10:12:55 -0500
committerJohn Crispin <john@phrozen.org>2016-09-19 19:32:35 +0200
commite9401a2335cc442bd06209ff7becdd60e940c3de (patch)
treec4feabd921c345c3644a2cd31051d4ddca8c4c25 /package
parent7219c30da49ae35a5f9dff8f11cd39e667b6b09e (diff)
downloadmaster-31e0f0ae-e9401a2335cc442bd06209ff7becdd60e940c3de.tar.gz
master-31e0f0ae-e9401a2335cc442bd06209ff7becdd60e940c3de.tar.bz2
master-31e0f0ae-e9401a2335cc442bd06209ff7becdd60e940c3de.zip
kernel: owl-loader for delayed Atheros ath9k fixup
Some devices (like the Cisco Meraki Z1 Cloud Managed Teleworker Gateway) need to be able to initialize the PCIe wifi device. Normally, this is done during the early stages of booting linux, because the necessary init code is read from the memory mapped SPI and passed to pci_enable_ath9k_fixup. However,this isn't possible for devices which have the init code for the Atheros chip stored on NAND in an UBI volume. Hence, this module can be used to initialze the chip when the user-space is ready to extract the init code. Martin Blumenstingl made a few fixes and added support for lantiq: kernel: owl-loader: add support for OWL emulation PCI devices kernel: owl-loader: don't re-scan the bus when ath9k_pci_fixup failed kernel: owl-loader: use dev_* instead of pr_* logging functions kernel: owl-loader: auto-generate the eeprom filename as fallback kernel: owl-loader: add a debug message when swapping the eeprom data kernel: owl-loader: add missing newlines in log messages kernel: owl-loader: add support for the lantiq platform These patches have been integrated. Thanks! Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com> Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 3f7a3ee1b1..a5e0f508db 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -1039,3 +1039,24 @@ define KernelPackage/bmp085-spi/description
endef
$(eval $(call KernelPackage,bmp085-spi))
+
+
+define KernelPackage/owl-loader
+ SUBMENU:=$(WIRELESS_MENU)
+ TITLE:=Owl loader for initializing Atheros PCI(e) Wifi chips
+ DEPENDS:=@PCI_SUPPORT +kmod-ath9k
+ KCONFIG:=CONFIG_OWL_LOADER
+ FILES:=$(LINUX_DIR)/drivers/misc/owl-loader.ko
+ AUTOLOAD:=$(call AutoProbe,owl-loader)
+endef
+
+define KernelPackage/owl-loader/description
+ Kernel module that helps to initialize certain Qualcomm
+ Atheros' PCI(e) Wifi chips, which have the init data
+ (which contains the PCI device ID for example) stored
+ together with the calibration data in the file system.
+
+ This is necessary for devices like the Cisco Meraki Z1.
+endef
+
+$(eval $(call KernelPackage,owl-loader))