summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2016-09-07 10:25:33 -0700
committerJohn Crispin <john@phrozen.org>2016-09-08 13:40:03 +0200
commit9a2f2f32cfd6f3230957a93d88ae48bb0ef2cb4a (patch)
tree9795a0e4737da7fb35ea7bfa05e5bf8d805ce590 /package
parente9f86c6cac1802eca052f98d3a5874521b2a87cd (diff)
downloadmaster-31e0f0ae-9a2f2f32cfd6f3230957a93d88ae48bb0ef2cb4a.tar.gz
master-31e0f0ae-9a2f2f32cfd6f3230957a93d88ae48bb0ef2cb4a.tar.bz2
master-31e0f0ae-9a2f2f32cfd6f3230957a93d88ae48bb0ef2cb4a.zip
e2fsprogs: Honor the global verbose flag
Look for OPENWRT_VERBOSE and pass it down to the e2fsprogs entry-point Makefile. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/utils/e2fsprogs/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/utils/e2fsprogs/Makefile b/package/utils/e2fsprogs/Makefile
index 247b5ed4a4..4e25ab0dc6 100644
--- a/package/utils/e2fsprogs/Makefile
+++ b/package/utils/e2fsprogs/Makefile
@@ -131,12 +131,14 @@ define Build/Compile
CFLAGS="" \
CPPFLAGS="" \
LDFLAGS="" \
+ V=$(if $(findstring c,$(OPENWRT_VERBOSE)),1,) \
subst
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
LDFLAGS=-Wl,--gc-sections \
BUILDCC="$(HOSTCC)" \
DESTDIR="$(PKG_INSTALL_DIR)" \
LIBBLKID="$(PKG_BUILD_DIR)/lib/libblkid.a -luuid" \
+ V=$(if $(findstring c,$(OPENWRT_VERBOSE)),1,) \
all
endef