summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2016-09-27 19:06:07 +0200
committerJohn Crispin <john@phrozen.org>2016-09-27 20:27:26 +0200
commit986ec565074ace44385c0c100cedacf8bd42c0e2 (patch)
treecee4239d92a2adf086a4ce2663055e31a0be8ac3 /package
parent376944c0abe4c073faab17c450c3df1b0acda626 (diff)
downloadmaster-31e0f0ae-986ec565074ace44385c0c100cedacf8bd42c0e2.tar.gz
master-31e0f0ae-986ec565074ace44385c0c100cedacf8bd42c0e2.tar.bz2
master-31e0f0ae-986ec565074ace44385c0c100cedacf8bd42c0e2.zip
rfkill: add fake rfkill support
allow building of modules depending on RFKILL even if RFKILL is not enabled. Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 358e83a4d4..ffb7b88ec1 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -398,7 +398,7 @@ define KernelPackage/rfkill
TITLE:=RF switch subsystem support
DEPENDS:=@USE_RFKILL +kmod-input-core
KCONFIG:= \
- CONFIG_RFKILL \
+ CONFIG_RFKILL_FULL \
CONFIG_RFKILL_INPUT=y \
CONFIG_RFKILL_LEDS=y \
CONFIG_RFKILL_GPIO=y