summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2016-09-07 10:25:34 -0700
committerJohn Crispin <john@phrozen.org>2016-09-08 13:40:03 +0200
commit2728512e1553301f2b13aba8497302f577a1f0eb (patch)
treec48e21cdfa89cda3d39f701b5288a3729a0fc8ee /package
parent9a2f2f32cfd6f3230957a93d88ae48bb0ef2cb4a (diff)
downloadmaster-31e0f0ae-2728512e1553301f2b13aba8497302f577a1f0eb.tar.gz
master-31e0f0ae-2728512e1553301f2b13aba8497302f577a1f0eb.tar.bz2
master-31e0f0ae-2728512e1553301f2b13aba8497302f577a1f0eb.zip
e2fsprogs: List all libraries explicitly
e2fsprogs would fail linking with external toolchains which would not be able to find several dependencies, explicit them. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/utils/e2fsprogs/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/utils/e2fsprogs/Makefile b/package/utils/e2fsprogs/Makefile
index 4e25ab0dc6..debc5bae8f 100644
--- a/package/utils/e2fsprogs/Makefile
+++ b/package/utils/e2fsprogs/Makefile
@@ -44,6 +44,7 @@ define Package/libext2fs
$(call Package/e2fsprogs/Default)
SECTION:=libs
CATEGORY:=Libraries
+ DEPENDS:=+libuuid
TITLE:=ext2/3/4 filesystem library
endef
@@ -138,6 +139,8 @@ define Build/Compile
BUILDCC="$(HOSTCC)" \
DESTDIR="$(PKG_INSTALL_DIR)" \
LIBBLKID="$(PKG_BUILD_DIR)/lib/libblkid.a -luuid" \
+ ELF_OTHER_LIBS="$(TARGET_LDFLAGS) -luuid" \
+ SYSLIBS="$(TARGET_LDFLAGS) -ldl -L$(PKG_BUILD_DIR)/lib/ -lcom_err" \
V=$(if $(findstring c,$(OPENWRT_VERBOSE)),1,) \
all
endef