summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-06-09 12:25:48 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-06-09 12:25:48 +0000
commitfd8ec241877a19ea3ee8842f274e8e1d6454186d (patch)
treeed081df3603a66a2f8ad4444413e542245e3eaa3 /package
parente3e2a170cd3f3254a82af0c43f91ad1281a8cac4 (diff)
downloadmaster-31e0f0ae-fd8ec241877a19ea3ee8842f274e8e1d6454186d.tar.gz
master-31e0f0ae-fd8ec241877a19ea3ee8842f274e8e1d6454186d.tar.bz2
master-31e0f0ae-fd8ec241877a19ea3ee8842f274e8e1d6454186d.zip
base-files: if an ip6addr without a prefix is given, assume /128 - otherwise the busybox utilities will interpret it as /0 and create an invalid default route
SVN-Revision: 27145
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/lib/network/config.sh5
2 files changed, 6 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 2ad6bdd516..23bd51a0bd 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=72
+PKG_RELEASE:=73
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/lib/network/config.sh b/package/base-files/files/lib/network/config.sh
index 7e4a53d0a7..76ba324973 100755
--- a/package/base-files/files/lib/network/config.sh
+++ b/package/base-files/files/lib/network/config.sh
@@ -235,6 +235,11 @@ setup_interface_static() {
config_get bcast "$config" broadcast
config_get metric "$config" metric
+ case "$ip6addr" in
+ */*) ;;
+ *:*) ip6addr="$ip6addr/128" ;;
+ esac
+
[ -z "$ipaddr" ] || $DEBUG ifconfig "$iface" "$ipaddr" netmask "$netmask" broadcast "${bcast:-+}"
[ -z "$ip6addr" ] || $DEBUG ifconfig "$iface" add "$ip6addr"
[ -z "$gateway" ] || $DEBUG route add default gw "$gateway" ${metric:+metric $metric} dev "$iface"