summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-10-24 13:04:54 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-10-24 13:04:54 +0000
commitf8af095002b743be0b70440f7db4a09a3e89760f (patch)
tree686bd372dc4739198e3782c8c2cc1d86babfd3b6 /package
parent1895d55e9db07bed0cadf9ce088a15299af735b4 (diff)
downloadmaster-31e0f0ae-f8af095002b743be0b70440f7db4a09a3e89760f.tar.gz
master-31e0f0ae-f8af095002b743be0b70440f7db4a09a3e89760f.tar.bz2
master-31e0f0ae-f8af095002b743be0b70440f7db4a09a3e89760f.zip
kernel: the camellia module name has changed in kernel 3.4
With the support for architecture optimized camellia routines, the original camellia module got renamed to camellia_generic, account for that. SVN-Revision: 33903
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/crypto.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/kernel/modules/crypto.mk b/package/kernel/modules/crypto.mk
index 984ccc1f9b..43a7cc3431 100644
--- a/package/kernel/modules/crypto.mk
+++ b/package/kernel/modules/crypto.mk
@@ -324,6 +324,9 @@ endef
$(eval $(call KernelPackage,crypto-sha1))
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.6.0)),1)
+camellia_mod_suffix=_generic
+endif
define KernelPackage/crypto-misc
TITLE:=Other CryptoAPI modules
@@ -347,7 +350,7 @@ define KernelPackage/crypto-misc
CONFIG_CRYPTO_WP512
FILES:= \
$(LINUX_DIR)/crypto/anubis.ko \
- $(LINUX_DIR)/crypto/camellia.ko \
+ $(LINUX_DIR)/crypto/camellia$(camellia_mod_suffix).ko \
$(LINUX_DIR)/crypto/cast5.ko \
$(LINUX_DIR)/crypto/cast6.ko \
$(LINUX_DIR)/crypto/fcrypt.ko \