summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-02-26 16:40:02 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-02-26 16:40:02 +0000
commitf880c4992dd7f2ff6506e04ccdad984797707f4e (patch)
tree773d5a4cd22b334e026df31051f9cd1dfd83918c /package
parenta2abc43104eb27e50d1560979924f7ab4023346d (diff)
downloadmaster-31e0f0ae-f880c4992dd7f2ff6506e04ccdad984797707f4e.tar.gz
master-31e0f0ae-f880c4992dd7f2ff6506e04ccdad984797707f4e.tar.bz2
master-31e0f0ae-f880c4992dd7f2ff6506e04ccdad984797707f4e.zip
toolchain: mark unavailable packages for musl libc
And make librt be an empty stub for musl libc. Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 35810
Diffstat (limited to 'package')
-rw-r--r--package/toolchain/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/toolchain/Makefile b/package/toolchain/Makefile
index ec5508a754..b9d582ee4d 100644
--- a/package/toolchain/Makefile
+++ b/package/toolchain/Makefile
@@ -172,6 +172,7 @@ endef
define Package/libthread-db
$(call Package/libc/Default)
+ DEPENDS:=@!USE_MUSL
TITLE:=POSIX thread library debugging support
endef
@@ -230,6 +231,7 @@ endef
define Package/ldd
$(call Package/libc/Default)
+ DEPENDS:=@!USE_MUSL
SECTION:=utils
CATEGORY:=Utilities
TITLE:=LDD trace utility
@@ -258,6 +260,7 @@ endef
define Package/ldconfig
$(call Package/libc/Default)
+ DEPENDS:=@!USE_MUSL
SECTION:=utils
CATEGORY:=Utilities
TITLE:=Shared library path configuration
@@ -479,10 +482,12 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
define Package/librt/install
$(INSTALL_DIR) $(1)/lib
+ ifneq ($(CONFIG_USE_MUSL),y)
$(CP) \
$(TOOLCHAIN_DIR)/lib/librt.so.* \
$(TOOLCHAIN_DIR)/lib/librt-$(LIBC_SO_VERSION).so \
$(1)/lib/
+ endif
endef
define Package/ldd/install