summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2011-11-03 15:16:50 +0000
committerJohn Crispin <john@openwrt.org>2011-11-03 15:16:50 +0000
commitf78a0b80cca60d58929cd8639a5aa24cac6ebd70 (patch)
tree41cc945a4b92238b4084ef629a784e84caca2232 /package
parent4263d93da056f19444fdd07acdea3a0c4b1e2c1c (diff)
downloadmaster-31e0f0ae-f78a0b80cca60d58929cd8639a5aa24cac6ebd70.tar.gz
master-31e0f0ae-f78a0b80cca60d58929cd8639a5aa24cac6ebd70.tar.bz2
master-31e0f0ae-f78a0b80cca60d58929cd8639a5aa24cac6ebd70.zip
modules: fixes ko files that were renamed in 3.1
SVN-Revision: 28724
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/i2c.mk10
-rw-r--r--package/kernel/modules/spi.mk5
2 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/modules/i2c.mk b/package/kernel/modules/i2c.mk
index eb3ac83576..0d525cc6d3 100644
--- a/package/kernel/modules/i2c.mk
+++ b/package/kernel/modules/i2c.mk
@@ -293,8 +293,13 @@ endef
$(eval $(call KernelPackage,i2c-mux-pca9541))
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.1.0)),1)
+GPIO_PCA953X_MODULES:= \
+ CONFIG_GPIO_PCA953X:drivers/gpio/gpio-pca953x
+else
GPIO_PCA953X_MODULES:= \
CONFIG_GPIO_PCA953X:drivers/gpio/pca953x
+endif
define KernelPackage/pca953x
$(call i2c_defaults,$(GPIO_PCA953X_MODULES),51)
@@ -308,8 +313,13 @@ endef
$(eval $(call KernelPackage,pca953x))
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.1.0)),1)
+GPIO_PCF857X_MODULES:= \
+ CONFIG_GPIO_PCF857X:drivers/gpio/gpio-pcf857x
+else
GPIO_PCF857X_MODULES:= \
CONFIG_GPIO_PCF857X:drivers/gpio/pcf857x
+endif
define KernelPackage/pcf857x
$(call i2c_defaults,$(GPIO_PCF857X_MODULES),51)
diff --git a/package/kernel/modules/spi.mk b/package/kernel/modules/spi.mk
index 7cb2a354dc..0c187b3a2f 100644
--- a/package/kernel/modules/spi.mk
+++ b/package/kernel/modules/spi.mk
@@ -62,8 +62,13 @@ define KernelPackage/spi-gpio
TITLE:=GPIO-based bitbanging SPI Master
DEPENDS:=@GPIO_SUPPORT +kmod-spi-bitbang
KCONFIG:=CONFIG_SPI_GPIO
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.1.0)),1)
+ FILES:=$(LINUX_DIR)/drivers/spi/spi-gpio.ko
+ AUTOLOAD:=$(call AutoLoad,92,spi-gpio)
+else
FILES:=$(LINUX_DIR)/drivers/spi/spi_gpio.ko
AUTOLOAD:=$(call AutoLoad,92,spi_gpio)
+endif
endef
define KernelPackage/spi-gpio/description