summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-07-08 09:01:42 +0000
committerJohn Crispin <john@openwrt.org>2013-07-08 09:01:42 +0000
commitf60cb8c3d907fc6e11a1e266e1e5d4ae3d0b7826 (patch)
treef591dbab9fad9df09322802a8708dcae182693dd /package
parentfc40051569e1adc3e1c3591f85cd24c61f839389 (diff)
downloadmaster-31e0f0ae-f60cb8c3d907fc6e11a1e266e1e5d4ae3d0b7826.tar.gz
master-31e0f0ae-f60cb8c3d907fc6e11a1e266e1e5d4ae3d0b7826.tar.bz2
master-31e0f0ae-f60cb8c3d907fc6e11a1e266e1e5d4ae3d0b7826.zip
ubox: add a uci-default script for fstab generation
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 37199
Diffstat (limited to 'package')
-rw-r--r--package/system/ubox/Makefile3
-rw-r--r--package/system/ubox/files/fstab.default1
2 files changed, 3 insertions, 1 deletions
diff --git a/package/system/ubox/Makefile b/package/system/ubox/Makefile
index 3824148f93..e964506385 100644
--- a/package/system/ubox/Makefile
+++ b/package/system/ubox/Makefile
@@ -48,9 +48,10 @@ define Package/ubox/install
endef
define Package/block-mount/install
- $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin $(1)/etc/hotplug.d/block $(1)/etc/init.d/
+ $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin $(1)/etc/hotplug.d/block $(1)/etc/init.d/ $(1)/etc/uci-defaults/
$(INSTALL_BIN) ./files/fstab.init $(1)/etc/init.d/fstab
+ $(INSTALL_DATA) ./files/fstab.default $(1)/etc/uci-defaults/10-fstab
$(INSTALL_DATA) ./files/mount.hotplug $(1)/etc/hotplug.d/block/10-mount
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/block $(1)/sbin/
diff --git a/package/system/ubox/files/fstab.default b/package/system/ubox/files/fstab.default
new file mode 100644
index 0000000000..dd4ba1c485
--- /dev/null
+++ b/package/system/ubox/files/fstab.default
@@ -0,0 +1 @@
+[ ! -f /etc/config/fstab ] && ( block detect > /etc/config/fstab )