summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorTim Yardley <lst@openwrt.org>2007-04-08 00:34:37 +0000
committerTim Yardley <lst@openwrt.org>2007-04-08 00:34:37 +0000
commitf114756689f36bbcba1d28e054145675aaf75655 (patch)
treed11cfe1642225ff4c021565c94cfe56aceae9e6b /package
parent169e9ea9a23425e9b48004cd49c31f6dab2e44a5 (diff)
downloadmaster-31e0f0ae-f114756689f36bbcba1d28e054145675aaf75655.tar.gz
master-31e0f0ae-f114756689f36bbcba1d28e054145675aaf75655.tar.bz2
master-31e0f0ae-f114756689f36bbcba1d28e054145675aaf75655.zip
update dropbear to 0.49
SVN-Revision: 6890
Diffstat (limited to 'package')
-rw-r--r--package/dropbear/Makefile7
-rw-r--r--package/dropbear/patches/120-hostkey_prompt.patch17
-rw-r--r--package/dropbear/patches/160-pam_header.patch19
3 files changed, 12 insertions, 31 deletions
diff --git a/package/dropbear/Makefile b/package/dropbear/Makefile
index 42955fd999..25a0cd0f55 100644
--- a/package/dropbear/Makefile
+++ b/package/dropbear/Makefile
@@ -9,12 +9,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=dropbear
-PKG_VERSION:=0.48.1
+PKG_VERSION:=0.49
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://matt.ucc.asn.au/dropbear/releases/
-PKG_MD5SUM:=ca8e53a766faec831882831364568421
+PKG_SOURCE_URL:=http://matt.ucc.asn.au/dropbear/releases/ \
+ http://www.mirrors.wiretapped.net/security/cryptography/apps/ssh/dropbear/
+PKG_MD5SUM:=7b20c85f1ee34f018a1b948eae003df9
include $(INCLUDE_DIR)/package.mk
diff --git a/package/dropbear/patches/120-hostkey_prompt.patch b/package/dropbear/patches/120-hostkey_prompt.patch
index 59639e7b97..d18bff86a2 100644
--- a/package/dropbear/patches/120-hostkey_prompt.patch
+++ b/package/dropbear/patches/120-hostkey_prompt.patch
@@ -1,12 +1,11 @@
-diff -urN dropbear-0.45.old/cli-kex.c dropbear-0.45/cli-kex.c
---- dropbear-0.45.old/cli-kex.c 2005-03-07 05:27:01.000000000 +0100
-+++ dropbear-0.45/cli-kex.c 2005-03-25 11:13:57.000000000 +0100
-@@ -119,7 +119,7 @@
- char response = 'z';
-
- fp = sign_key_fingerprint(keyblob, keybloblen);
+--- dropbear-0.49/cli-kex.c.orig 2007-02-22 09:51:36.000000000 -0600
++++ dropbear-0.49/cli-kex.c 2007-03-22 13:45:57.000000000 -0500
+@@ -126,7 +126,7 @@
+ m_free(fp);
+ return;
+ }
- fprintf(stderr, "\nHost '%s' is not in the trusted hosts file.\n(fingerprint %s)\nDo you want to continue connecting? (y/n)\n",
-+ fprintf(stderr, "\nHost '%s' is not in the trusted hosts file.\n(fingerprint %s)\nDo you want to continue connecting? (y/n) ",
++ fprintf(stderr, "\nHost '%s' is not in the trusted hosts file.\n(fingerprint %s)\nDo you want to continue connecting? (y/n)",
cli_opts.remotehost,
fp);
-
+ m_free(fp);
diff --git a/package/dropbear/patches/160-pam_header.patch b/package/dropbear/patches/160-pam_header.patch
deleted file mode 100644
index 1c900f7169..0000000000
--- a/package/dropbear/patches/160-pam_header.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -ur dropbear.old/svr-authpam.c dropbear.dev/svr-authpam.c
---- dropbear.old/svr-authpam.c 2006-03-12 05:52:52.000000000 +0100
-+++ dropbear.dev/svr-authpam.c 2007-02-27 02:55:41.382234344 +0100
-@@ -31,14 +31,13 @@
- #include "dbutil.h"
- #include "auth.h"
-
-+#ifdef ENABLE_SVR_PAM_AUTH
- #if defined(HAVE_SECURITY_PAM_APPL_H)
- #include <security/pam_appl.h>
- #elif defined (HAVE_PAM_PAM_APPL_H)
- #include <pam/pam_appl.h>
- #endif
-
--#ifdef ENABLE_SVR_PAM_AUTH
--
- struct UserDataS {
- char* user;
- char* passwd;