summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-03-15 14:48:18 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-03-15 14:48:18 +0000
commiteb7f470e7bf98aaef29968b3a03c8a5cd23fa536 (patch)
tree71c674f84572109e4d311863574323996615108a /package
parent085b8e0014564a2d5e11c45178109c39c8f31a10 (diff)
downloadmaster-31e0f0ae-eb7f470e7bf98aaef29968b3a03c8a5cd23fa536.tar.gz
master-31e0f0ae-eb7f470e7bf98aaef29968b3a03c8a5cd23fa536.tar.bz2
master-31e0f0ae-eb7f470e7bf98aaef29968b3a03c8a5cd23fa536.zip
netifd: dhcp: install host route to gateway (#19182)
Certain DHCP servers push a gateway outside of the assigned interface subnet, to support those situations install a host route towards the gateway. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44789
Diffstat (limited to 'package')
-rw-r--r--package/network/config/netifd/Makefile2
-rwxr-xr-xpackage/network/config/netifd/files/lib/netifd/dhcp.script1
2 files changed, 2 insertions, 1 deletions
diff --git a/package/network/config/netifd/Makefile b/package/network/config/netifd/Makefile
index 81af3a72e5..d1891902d0 100644
--- a/package/network/config/netifd/Makefile
+++ b/package/network/config/netifd/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=netifd
-PKG_VERSION:=2015-03-06
+PKG_VERSION:=2015-03-15
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
diff --git a/package/network/config/netifd/files/lib/netifd/dhcp.script b/package/network/config/netifd/files/lib/netifd/dhcp.script
index 288ab18d00..a3219a0701 100755
--- a/package/network/config/netifd/files/lib/netifd/dhcp.script
+++ b/package/network/config/netifd/files/lib/netifd/dhcp.script
@@ -19,6 +19,7 @@ setup_interface () {
# TODO: apply $broadcast
for i in $router; do
+ proto_add_ipv4_route "$i" 32 "" "$ip"
proto_add_ipv4_route 0.0.0.0 0 "$i" "$ip"
done