summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-05-09 10:48:36 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-05-09 10:48:36 +0000
commite976bf56006ea3709c60a8ada379e6efe0d6af9c (patch)
tree347e96ff766025a709c391d39b9f76cf491e9ae2 /package
parent0f8e0335a7759ce0abf369ab0bc27b43e92b4b0e (diff)
downloadmaster-31e0f0ae-e976bf56006ea3709c60a8ada379e6efe0d6af9c.tar.gz
master-31e0f0ae-e976bf56006ea3709c60a8ada379e6efe0d6af9c.tar.bz2
master-31e0f0ae-e976bf56006ea3709c60a8ada379e6efe0d6af9c.zip
package/kernel: add package for the ADT7473/7475/7476/7490 sensors
SVN-Revision: 31657
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/hwmon.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/modules/hwmon.mk b/package/kernel/modules/hwmon.mk
index 94f21a67e4..d549336b3d 100644
--- a/package/kernel/modules/hwmon.mk
+++ b/package/kernel/modules/hwmon.mk
@@ -45,6 +45,21 @@ endef
$(eval $(call KernelPackage,hwmon-vid))
+define KernelPackage/hwmon-adt7475
+ TITLE:=ADT7473/7475/7476/7490 monitoring support
+ KCONFIG:=CONFIG_SENSORS_ADT7475
+ FILES:=$(LINUX_DIR)/drivers/hwmon/adt7475.ko
+ AUTOLOAD:=$(call AutoLoad,60,adt7475)
+ $(call AddDepends/hwmon,+kmod-i2c-core +kmod-hwmon-vid)
+endef
+
+define KernelPackage/hwmon-adt7475/description
+ Kernel module for ADT7473/7475/7476/7490 thermal monitor chip.
+endef
+
+$(eval $(call KernelPackage,hwmon-adt7475))
+
+
define KernelPackage/hwmon-lm63
TITLE:=LM63/64 monitoring support
KCONFIG:=CONFIG_SENSORS_LM63