summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-07-28 02:18:16 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-07-28 02:18:16 +0000
commite47a8a001c37a32ac2ccd50bb9b6eae1c929fdfa (patch)
tree2318d225f10c4b1389ac1b71afa1e19f0c92f173 /package
parentceeb9a8013e4416953d7ced30893ff87375a85b9 (diff)
downloadmaster-31e0f0ae-e47a8a001c37a32ac2ccd50bb9b6eae1c929fdfa.tar.gz
master-31e0f0ae-e47a8a001c37a32ac2ccd50bb9b6eae1c929fdfa.tar.bz2
master-31e0f0ae-e47a8a001c37a32ac2ccd50bb9b6eae1c929fdfa.zip
revert r22372 and r22405, dependency on host libtool causes problems
SVN-Revision: 22406
Diffstat (limited to 'package')
-rw-r--r--package/Makefile9
-rw-r--r--package/opkg/Makefile24
2 files changed, 4 insertions, 29 deletions
diff --git a/package/Makefile b/package/Makefile
index 3c7b0b49bc..5468bdc718 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -12,7 +12,6 @@ $(curdir)/builddirs:=$(sort $(package-) $(package-y) $(package-m))
ifeq ($(SDK),1)
$(curdir)/builddirs-install:=.
else
- $(curdir)/base-files/compile += $(curdir)/opkg/host/compile
$(curdir)/builddirs-default:=. $(sort $(package-y) $(package-m))
$(curdir)/builddirs-prereq:=. $(sort $(prereq-y) $(prereq-m))
$(curdir)/builddirs-install:=. $(sort $(package-y))
@@ -89,9 +88,9 @@ $(curdir)/index: FORCE
$(curdir)/flags-install:= -j1
$(eval $(call stampfile,$(curdir),package,prereq,.config))
-$(eval $(call stampfile,$(curdir),package,cleanup))
-$(eval $(call stampfile,$(curdir),package,compile))
-$(eval $(call stampfile,$(curdir),package,install))
-$(eval $(call stampfile,$(curdir),package,rootfs-prepare))
+$(eval $(call stampfile,$(curdir),package,cleanup,$(TMP_DIR)/.build))
+$(eval $(call stampfile,$(curdir),package,compile,$(TMP_DIR)/.build))
+$(eval $(call stampfile,$(curdir),package,install,$(TMP_DIR)/.build))
+$(eval $(call stampfile,$(curdir),package,rootfs-prepare,$(TMP_DIR)/.build))
$(eval $(call subdir,$(curdir)))
diff --git a/package/opkg/Makefile b/package/opkg/Makefile
index 3a5ba449f1..c18f8e7319 100644
--- a/package/opkg/Makefile
+++ b/package/opkg/Makefile
@@ -18,9 +18,7 @@ PKG_SOURCE_SUBDIR:=opkg-$(PKG_VERSION)
PKG_SOURCE_URL:=http://opkg.googlecode.com/svn/trunk/
PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
PKG_FIXUP = libtool
-
include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/host-build.mk
define Package/opkg
SECTION:=base
@@ -82,25 +80,3 @@ define Build/InstallDev
endef
$(eval $(call BuildPackage,opkg))
-
-
-HOST_CONFIGURE_ARGS += \
- --disable-curl \
- --disable-gpg \
- --with-opkgetcdir=/etc \
- --with-opkglockfile=/tmp/opkg.lock
-
-define Host/Configure
- (cd $(HOST_BUILD_DIR); autoreconf -v --install || exit 1)
- $(call Host/Configure/Default)
-endef
-
-define Host/Compile
- $(MAKE) -C $(HOST_BUILD_DIR) CC="$(HOSTCC)" all
-endef
-
-define Host/Install
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/src/opkg-cl $(STAGING_DIR_HOST)/bin/opkg
-endef
-
-$(eval $(call HostBuild))