summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-07-07 09:43:04 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-07-07 09:43:04 +0000
commite42f0f49e888d7e5ee3e9531b533b0e8255c507b (patch)
treef3bc76af365762a700237d99c390c0f9c6fa9fa2 /package
parenta3e343b722f2fc27bfb4e5c6017734fcc9f15b06 (diff)
downloadmaster-31e0f0ae-e42f0f49e888d7e5ee3e9531b533b0e8255c507b.tar.gz
master-31e0f0ae-e42f0f49e888d7e5ee3e9531b533b0e8255c507b.tar.bz2
master-31e0f0ae-e42f0f49e888d7e5ee3e9531b533b0e8255c507b.zip
add perf
SVN-Revision: 27515
Diffstat (limited to 'package')
-rw-r--r--package/perf/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/package/perf/Makefile b/package/perf/Makefile
new file mode 100644
index 0000000000..88b706d49e
--- /dev/null
+++ b/package/perf/Makefile
@@ -0,0 +1,52 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=perf
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/perf
+ SECTION:=utils
+ CATEGORY:=Utilities
+ DEPENDS:= +libdw +libelf +libpthread +librt
+ TITLE:=Linux performance monitoring tool
+ VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
+ URL:=http://www.kernel.org
+endef
+
+define Package/perf/description
+ perf is the Linux performance monitoring tool
+endef
+
+define Build/Prepare
+endef
+
+define Build/Compile
+ $(MAKE) -C $(LINUX_DIR)/tools/perf \
+ ARCH="$(LINUX_KARCH)" \
+ NO_LIBPERL=1 \
+ NO_LIBPYTHON=1 \
+ NO_NEWT=1 \
+ CROSS_COMPILE="$(TARGET_CROSS)" \
+ CC="$(TARGET_CC)" \
+ LD="$(TARGET_CROSS)ld" \
+ CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+ LDFLAGS="$(TARGET_LDFLAGS)" \
+ V=1 \
+ prefix=/usr
+endef
+
+define Package/perf/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(LINUX_DIR)/tools/perf/perf $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,perf))