summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-03-16 01:25:42 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-03-16 01:25:42 +0000
commite3bdc13980dea05f9cd0fbd24cd0229c531c6e02 (patch)
tree75dce3a929a1294226cf397c7f63d44314306c60 /package
parent132a54f6468793348b5f713f59cb55c68ecfdba1 (diff)
downloadmaster-31e0f0ae-e3bdc13980dea05f9cd0fbd24cd0229c531c6e02.tar.gz
master-31e0f0ae-e3bdc13980dea05f9cd0fbd24cd0229c531c6e02.tar.bz2
master-31e0f0ae-e3bdc13980dea05f9cd0fbd24cd0229c531c6e02.zip
busybox: fix disabling /sbin/init and logread if procd is used as init
SVN-Revision: 36054
Diffstat (limited to 'package')
-rw-r--r--package/busybox/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index f4553c0ffe..ed58fabcfd 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -62,7 +62,7 @@ endef
define Build/Configure
rm -f $(PKG_BUILD_DIR)/.configured*
grep 'CONFIG_BUSYBOX_' $(TOPDIR)/.config | sed -e "s,\\(# \)\\?CONFIG_BUSYBOX_\\(.*\\),\\1\\2,g" > $(PKG_BUILD_DIR)/.config
- yes '' | $(MAKE) -C $(PKG_BUILD_DIR) \
+ yes 'n' | $(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
CROSS_COMPILE="$(TARGET_CROSS)" \
KBUILD_HAVE_NLS=no \
@@ -113,7 +113,6 @@ define Package/busybox/install
$(INSTALL_BIN) ./files/$$$$tmp $(1)/etc/init.d/$$$$tmp; \
done
-rm -rf $(1)/lib64
- $(if $(CONFIG_PROCD_INIT),rm -f $(1)/sbin/init $(1)/sbin/logread)
endef
$(eval $(call BuildPackage,busybox))