summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-09-27 20:44:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-09-27 20:44:11 +0000
commite232a92c0886d334a72823b7183ccac08815b755 (patch)
treeb2ea8a4ca6b50c3061d544d9d79eb59fd41c0c69 /package
parent03e14c13e3b1981baf6e4eeca1ce9ee41e634dcc (diff)
downloadmaster-31e0f0ae-e232a92c0886d334a72823b7183ccac08815b755.tar.gz
master-31e0f0ae-e232a92c0886d334a72823b7183ccac08815b755.tar.bz2
master-31e0f0ae-e232a92c0886d334a72823b7183ccac08815b755.zip
kernel: mark kmod-thermal menuconfig symbol as hidden to avoid building it on targets with no thermal drivers
Should fix build errors with Linux 3.3/3.6 targets, which use different kconfig symbols Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 38238
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index cbce02bbf5..b3e268e79c 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -765,6 +765,7 @@ $(eval $(call KernelPackage,random-core))
define KernelPackage/thermal
SUBMENU:=$(OTHER_MENU)
TITLE:=Generic Thermal sysfs driver
+ HIDDEN:=1
KCONFIG:= \
CONFIG_THERMAL \
CONFIG_THERMAL_DEFAULT_GOV_STEP_WISE=y \