summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-04-01 08:31:26 +0000
committerJohn Crispin <john@openwrt.org>2015-04-01 08:31:26 +0000
commite078fbdacf120eb8da0bc7e4d1f8f90849c7f1d2 (patch)
treefed4ca4bb575e9bc06832dc75a029659a5658c24 /package
parentbf828d3fd096df494f43dd53e2358ef511dc5775 (diff)
downloadmaster-31e0f0ae-e078fbdacf120eb8da0bc7e4d1f8f90849c7f1d2.tar.gz
master-31e0f0ae-e078fbdacf120eb8da0bc7e4d1f8f90849c7f1d2.tar.bz2
master-31e0f0ae-e078fbdacf120eb8da0bc7e4d1f8f90849c7f1d2.zip
kernel: add missing symbols to config and modules
Signed-off-by: Daniel Golle <daniel@makrotopia.org> v2: changes in input.mk broke the patch, some of the CONFIG_SND_* stuff was added already SVN-Revision: 45205
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/input.mk2
-rw-r--r--package/kernel/linux/modules/other.mk1
2 files changed, 2 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index 6c9f228497..b44136b78c 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -11,7 +11,7 @@ define KernelPackage/hid
SUBMENU:=$(INPUT_MODULES_MENU)
TITLE:=HID Devices
DEPENDS:=+kmod-input-core +kmod-input-evdev
- KCONFIG:=CONFIG_HID CONFIG_HIDRAW=y
+ KCONFIG:=CONFIG_HID CONFIG_HIDRAW=y CONFIG_HID_BATTERY_STRENGTH=y
FILES:=$(LINUX_DIR)/drivers/hid/hid.ko
AUTOLOAD:=$(call AutoLoad,61,hid)
endef
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 18edaeffc5..6a5825011c 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -746,6 +746,7 @@ define KernelPackage/zram
CONFIG_ZRAM \
CONFIG_ZRAM_DEBUG=n \
CONFIG_PGTABLE_MAPPING=n \
+ CONFIG_ZSMALLOC_STAT=n \
CONFIG_ZRAM_LZ4_COMPRESS=y
FILES:= \
$(LINUX_DIR)/drivers/staging/zsmalloc/zsmalloc.ko@lt3.14 \